PDA

View Full Version : Need help with 35mm SLR camera



Wally_in_Cincy
03-14-2003, 01:45 PM
I have a Ricoh 35mm SLR camera (circa 1986). Exposure is automatic, everything else is manual. It's been a trusty soldier all these years but now I have a problem. When you are loading the film you stick the film on the take-up spool, click the shutter, wind, click the shutter, wind, etc. until the film is firmly on the spool.

When I got it out the other day and tried to load a new roll of film the shutter doesn't work (and no, it's not on "lock"). The batteries are new and I know they are good because the exposure meter in the viewfinder works.

Any photographers out there got any suggestions?

Rod
03-14-2003, 02:42 PM
Geez Wally your stuff is as old as mine. Have you tried taking the lens off the body. Not sure it will help but you never know.

Rod

bluewolf
03-14-2003, 02:44 PM
I have done photography but no expert. If the shutter advance is not working, I would think that a piece in it is broken or a piece has broken off and is caught in the spool causing it to not advance. Whatever the problem is, I would take it to a good photo shop so that they can diagnose the problem. I personally like those old ricohs too. Great cameras

Laura

nAz
03-14-2003, 02:46 PM
Wally have you tried slamming it down on a pool table? that may loosen things up a bit /ccboard/images/graemlins/smile.gif
the only thing i can think of is that the battery is Kaput! but since you said its good i can't think of anything else.

Leviathan
03-14-2003, 04:02 PM
Is the shutter driven by a spring? Springs break.--D.M.